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Exercises

Import data with Wizard

User interface

Heatmap

ANOVA (F-test) — Export Variable list
t-test — Work with synchronized plots
Templates

Box plot, Volcano plot

Import and analyze GEO data
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Exploratory Data Analysis
t-SNE plot
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Exercise 1 — Import data with the Wizard

2/20/20

Select File/Open Wizard

Select the file Data Import example.txt
Select Wizard

Step through the Wizard

The dataset is loaded and a Sample PCA plot
is displayed

Select Method/Table to view the imported
table of values.

Save the data set as a gedata-file (File/Save
as) on your Desktop

Close the dataset

«® File import wizard

Step 7of 8

Column/sample annotations

Ciick in a cell again to deselect .

Select row header cells or the leftmost annotation cels if there are no annotation headers.

1 2 3 4
1 SampleID
2 Age
3 Gender
4 Treatment
5 Rank
6 Censor
7 VariablelD Symbol  Name
8 D01 ENCL Variable...
9 1002 CDK3 Variable.
10 1003 PEXT Variable.
11 1D_04 VPS13D  Variable...
12 D05 DLX6 Variable
13 ID_06 SFRS9  Variable...
14 D07 ABCFL  Variable.
15 ID_08 DADL  Variable...
16 D09 W Variable
17 1010 B Variable...
18 ID_11 VPS13D  Variable.
19 1012 CLASP2  Variable.
20 D13 MYO1B  Variable...
21 D14 CLASP2  Variable.
22 D15 CLASP2  Variable...
B‘ D_16 MIA3 Variable
<
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Exercise 2 Uer Interface: Tools

—
Samples log  NGS i
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(M Drug 1 4/4
- Drug 2 4/4 Variable List Properties ~ Comments
IZI:' Placebo 4/4 Property Value A
Name Qlucore Test Data Set.geda...
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10.

Exercise 2: Tools

Open the Data Import Example gedata-file that you saved.(Either by
doubleclicking on the file or by File/Open)

Select Mouse tool Move (default). Rotate the PCA plot with the mouse to look
at it from different angles.

Select mouse tool Label and label one/several samples by clicking on a sample/
circling several samples with the mouse (clockwise) (Note that the Multi check
box in the upper left corner must be marked)

Undo by pressing Clear and reset the Mouse tool to Move

Go to the Samples tab and colour the samples by Age, Gender and Treatment
pressing the colour icon

See how the samples seem to cluster based on Treatment in the Sample PCA
plot

Go to the Variables tab.

Click on the active list and see the detailed list of the variables below.
Add the column Symbol to the list using the column selector symbol
Close the dataset

@ Move

@ Label

Multi.

 Clear

P 4
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Exercise 3 Heatmap: Steps

Open the Data Import Example gedata-file Plot Settings
Select Heatmap in the Method tab Sam. Size {
Select the View Tab and press Size/AUTO to show all samples and Var. Size | Aut. ||
variables :
Then change the variable label to Symbol (Label/Var) - SamplelD .

5.  Go to the View Tab and change Order to Hierarchical clustering for Yor. |Svbo M
both the samples and the variables | view | cluster | Buid Classific
Color the samples according to the Treatment annotation. szﬁ,er[H,dummg 2
Color by additional annotations e.g. Age and Gender| # Var. [H. dustering v
(View/Colour/Sam/Additional annotations) oo | vetod [ ooton |
Colour the variables by Variance (View/Colour/Var) s:\'f
Use the Flip Mouse tool to flip the clusters |@ Flip Var.

10. Change the heatmap colours in View/Plot Settings/More Plot Settings

11. Zoom in the variables by using the arrows in View/Plot Settings. Reset s, sie [ 133 & IR
by pressing Auto. Var.Sze [Aut [0 2 [ More |

12. Export the plot (File/Export/Image)
13. Open the exported file
14. Close the file and the dataset
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Exercise 4 ANOVA: Steps

1. Open the Data Import Example gedata-file and
select Heat map in the Methods tab.

2. Colour according to Treatment and perform hierarchical clustring
. . . Lo . Filter by  Multi Group Comparison  +
3. Select Multi group comparison in the Statistics dialogue.
Treatment v

4, Select the annotation Treatment.
5. Drag the p-value slider in the Statistics dialog. Monitor the p-values and g- 0

values of the remaining variables. Note that the heatmap is instantly updated p= 1 g q=1 g
6. Create a list of the variables by making a copy of the active variable list (Data

Import Example) in the Variables tab. I
7. Double click on the list to rename it.
8. Add more information to the list by clicking on the column selector icon and

select symbol. Add p-value and g-value. m
9. Add a comment. (Mark the list and select the comment tab in the bottom part h

of the Window)
10. Export the list to your computer (select the Export icon) (include annotations) ~
11.  Openthe list and look at the content. L
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Exercise 5 t-test: Steps

Select the Qlucore Test Data Set from the Help Menu/Example Files

2. Select Window/New synchronized plot and
Tile the Plots using CTRL+T or Cmd+T
3. Colour the the Sample PCA plot according to Treatment
Make the other plot a heat map, hierarchically clustered and Lé
coloured according to Treatment
. @ Drug 1
5. Deselect Drug 2 under Treatment annotation in the sample tab - ™ org2 |
uncheck the check box. O] Placebo
6. Select Two Group comparison in the Statistics dialogue and
Treatment = Drug 1
7. Drag the statistical slider to find discriminating variables,
stop at a g-value = 0.01
8. Note that the same clusters can be viewed in both the sample PCA and the heatmap
9. Create New Variable list by clicking on the icon in the variables tab. lsts [T
10.  Change the Mouse tool to List @ List
11.  Select the upregulated genes for the Drug 1 group with

the list tool (select the node in the heatmap)

ﬁ‘—\
12.  Rename the list and export it. =1 | m*
13.  Goto the log tab and print a pdf report summary
PDF| A I lz.m
1) - m

mmmmmmmm
wwwwwwww

Extra Exercise — make a t-test of Placebo vs both the treated groups
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10.

11.

Exercise 6 Box Plot: Steps

Data Method Options View Cluster
Plot
® PcaA O Line O Heat Genome

QO scatter O Bar O Table O Special All

Select the Qlucore Test Data Set from the Help Menu/Example Files

Open a Box Plot by pressing the “All” button in the Method tab and
select Box Sample

Select the Treatment annotation in the X-axis data selection (1%)

O PCA Sample O Histogram Variable O Kaplan-Meier
O PCA Variable O Bar sample O silhouette
O Scatter Sample @ Box Sample O Venn

O Scatter Variable O Heat O Talus

O Line Sample O Table O Scree

O Line Variable O Volcano Genome

(@) Histogram Sample O 2D t-SNE

|”

Select “Variables selected by y-axis tool” on y-axis data selection and
select one or several variables from the active list in the Variable tab
with the mouse

Double click on the y-axis to open the plot settings and change
Variable title to Gene symbol.

Go to the Options tab and tick the box samples to show both samples
and boxes.

Mode Axis Data Selection Normalization

kt. @ Sample X ) None () Meg
ariable Y __Manual Var, v @ Mean=0, Var=|

Y Axis Data
None

@) Variables selected by Y Axis tool
*) Variables for which the

equals

Tick and untick the other boxes and see how it affects the plot.
Add different p-values
Go to the Method tab and add

Plot Settings

General X Axis Y Axis

Show Axis [_] Enable Manual Area Control

Gender as a 2" x-axis

75 |%| Top Perc. Outliers

Export the image — File/Export/Image in

Title
@ Default | VariableID v
~
Data Method Options View Cluster Build Classifier Classify
Computations and Overlays Significance

Boxes Median [ Samples [ student [] Holm-Bonferroni

your preferred file format.
Open the exported file.

Course material — Basic

25 |2 Bottom Perc. [ ] T Max./Min. Colors [] Mean Gradients Tukey Fold Change 3 5| Precision
X Axis Data
None

@® Box 1%t ‘Treatment ~ ‘

2nd l Gender ~ ‘

training. © Qlucore 2019
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Exercise 7 Templates: Steps

1. Open the Qlucore Test Data set from the Help menu.

2. Click on the launch button for the
Templates.

3. Template 1: Select the Heatmap sample clustering template,
select the annotation Treatment, press Execute

4. Template 2: Select the Multigroup ANOVA
template/annotation Treatment/g=0.1/Execute

5. Template 3: Select t-test & Fold change/annotation
Treatment= Placebo/g=0,1/Fold change=2/Execute

2/20/20 Course material — Basic training. © Qlucore 2019
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Exercise 8 GEO data: Steps

1. Import a data set from GEO. Search for GSE13425 (childhood ALLs). (If no internet
connection - find the data set on a USB stick)

2. Colour the samples according to the annotation [*, Qlucore Omics Explorer 3.1 |
characteristics_ch1. %]NV:W R

3. Select Multi group comparison in the Statistics dialog. ; gzz:--v-vith _—
Select the annotation characteristics_chl. @ Open BAM files...

5. Drag the p-value slider in the Statistics dialog and filter to lﬁ] fmvpoi
the 800 most significant variables that separates the disease subtypes. YT

6. Open up a new synchronized plot, and make it a heatmap = E"'”" ......

7. Select hierarchical clustring for both samples and variables.

8. Colour the samples according to characteristics_ch1. ng‘or Method  Optiq

9. Show all the sample annotations in the heatmap Sarm.

(ViEW/COlOr/Sam.) Var. R-statistic

10. Colour the variables according to g-value(View/Colour/Var.)
11. Copy the active list, rename, add more information and export it.

12. Change the statistical test to a Two Group comparison (t-test) on T-ALL and p-value
filtration down to 800 variables

. . Data Method Options View Cluster Build Classifier
13. Open up a new synchronized plot and make it a Volcano plot — select fr e Type
. . L. . Ovprca O Line O Heat Genome Volcano
14. Colour it according to R-statistics (View/Colour/Var) ® satter O sor O Table O specil

15. Tile the plots (Ctrl T/Cmd T)

Course material — Basic training. © Qlucore 2019
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10.
11.

Exercise 9 Exploration: Steps

Load the Acute Lymphoblastic Leukemia.gedata data set

from the Help menu. e
Look at the data. Can you see any patterns? . -
Remove variables with low variance by moving zebfor:,earest
the variance slider oist. [
Find the maximum Projection Score, 0.43. , n
Annotations [
Use networks to connect each sample to its closest
neighbors. S
Create a new sample annotation. e Ame
Color the data set according to the new annotation. P L
Create a new annotation value. @® Annot.
Select the Mouse tool Annotate and annotate the found Multi

group by circling the samples clockwise with the mouse
(Make sure that the Multi checkbox is marked)

Deselect the found group.
Repeat steps 5-10.

Course material — Basic training. © Qlucore 2019
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Exercise 10 - t-SNE plot

* Keep the settings from previous exercise.

 Open a new synchronized plot and change it to a t-SNE plot.

(Scatter/Type = 2D t-SNE)
* Press Calc (Method tab)

* Change Perplexity to 5 and press Calc again.

* Test other Perplexity values

e Use the annotate tool to re-annotate if needed

S
o> TF

BN EEEEE R

t-SNE

Perplexity |5 =

More

Calc

Course material — Basic training. © Qlucore 2019 =
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Steps to add annotations

Select File/Open with Wizard
Select the file Data Import Example Without Annotations

Check the sample annotations in the Sample tab and see that you only have
one annotation — Sample id

Select File/Import/Sample annotations
Select the file Sample Annotations.txt
Import all the annotations

S -

Check the sample annotations in the Sample tab and see that you now have
all 6 annotations

Another way of creating the sample annotation file:
Close the dataset and import it again (without annotations)

2.  Perform File/Export/Sample annotations
3. Open the file in Excel and add one column per annotation.
4.  Save the file (txt) and import as in steps 4-6.

Course material — Basic training. © Qlucore 2019
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EE3: Steps

1. Load the Leukemia dataset from the
Help menu

2. Perform a Multigroup comparison on Leukemia Subtyp
— use the p-value slider and filter to approx 500
variables

Samples Variables Log ‘

Variables
Variable Lists | | X 2| L@ H
® Q@

3. Copy the list and call it "F-test”

VI
VI
[ O F-test
[ O t-test
[ O Intersection

[C] O iff

[] Search
Qlucore Test Data Set.gedata 1
Acute Lymphoblastic Leukemia.g...

0 0
50 0
501 501
502 502
501 501
211 211
291 291

4. Perform a two group comparison on
Leukemia subtype T-ALL and filter to
app. 500 variables

5. Copy the list and call it "t-test”

6. Use the Set Operations tool and make an
intersection of the lists — rename the list “Intersection”

7. Use the Set Operations tool and make a difference
between F-test and t-test. Rename the list Diff.

Venn Diagram

Course material — Basic training. © Qlucore 2019
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EE4- Steps

e Start by saving your open data set
as a gedata file. File/Save as

* Gotothelogtab and create
a new log file

Log file

Log points

Ll

 Then create a logpoint and rename it.

* Close the volcano plot and change the statistical filtering

 Save a new logpoint — rename it.
* C(Close the software

* Click on the logfile to open the software and load the logfile.

* Restore logpoint 1 by clicking on the Restore icon.

 Then restore logpoint 2.

Log points U '[T”'
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